ROS bridge in combination with synchronous mode and fixed-delta-seconds

Hello carla community,

I’m currently trying to use the ROS bridge in combination with fixed-delta-seconds. I’m using carla version 0.9.10 and the newest version of the ROS bridge 0.9.10.1. I set the synchronous mode parameters like this:

  • ‘synchronous_mode’ default=‘true’
  • ‘synchronous_mode_wait_for_vehicle_control_command’ default=‘true’
  • ‘fixed_delta_seconds’ default=‘0.01’

If do so the simulation runs so slow I can’t even see the vehicle moving. If change the last parameter to ‘fixed_delta_seconds’ default=‘0.05’ everything runs smootly. Since I want to implement vehicle controllers I need the fixed delta seconds to be at least 0.01. I checked with the synchronous_mode.py in the python examples and if I set the fixed_delta_time there to 0.01 everything still runs smoothly.

Does anyone have an idea why the ROS bridge cannot handle small fixed delta times.

Any help is highly appreciated
Jeremy

Hi Jeremy,
Thank you for the message. I’ve been able to reproduce your issue (even setting synchronous_mode_wait_for_vehicle_control_command to false). I’ve opened an issue in the github repo to keep track of the fixes for this bug: https://github.com/carla-simulator/ros-bridge/issues/491

Hi Jeremy,
The issue should now be fixed in master. Please see https://github.com/carla-simulator/ros-bridge/issues/491