Launching carla error

Dear forum users, and developers!

Me and my friend need some help with Carla, we ran in to a big problem and don’t know what to do.

We want to make a new map based on our university, so we need it with buildings. And want to run our python script on the server (just a car driving it self on a specific road). We built Carla from source based on your Linux build tutorial. We made an .fbx file with Blender (it was easier), and made an .xodr file with some python script. Then we imported it with make import. Now this level can be selected in Unreal Engine.
Before all of this we managed to run manual_control.py on Town03 after we pressed the Play button in UE Editor, but the server was running with 3 fps. After we pressed the Launch button in UE Editor, it gave this error:
Error: RunUAT ERROR: AutomationTool was unable to run successfully. [2021.04.21-14.33.14:609][265]PackagingResults: Error: Launch failed! Unknown Error
Cannot Create Vulkan device. Try updating your video driver to a more recent version

If we select our new map and press the Play button, and tried to run the manul_control.py it gave this error:
File “manual_control.py”, line 288, in modify_vehicle_physics
physics_control = vehicle.get_physics_control()
RuntimeError: unable to get actor physics control: actor not found
and the Launch gave the same error as before.

We have installed:

  • Carla Linux build
  • Ubuntu 18.04
  • Clang 8.0.1
  • Python 3.6