Installing problems using Quick Star

Hi everyone,

I’m trying to install CARLA on my Linux Computer (16.04.7 Xenial Xerus), but it isnt working.

At first i tried the A Opotion: Debian CARLA Installation. But by the command “sudo apt-get update” i get the following error:

W: The repository ‘http://dist.carla.org/carla-0.9.9 xenial Release’ does not have a Release file.
N: Data from such a repository can’t be authenticated and is therefore potentially dangerous to use.
N: See apt-secure(8) manpage for repository creation and user configuration details.
E: Failed to fetch http://dist.carla.org/carla-0.9.9/dists/xenial/main/binary-amd64/Packages 404 Not Found
E: Some index files failed to download. They have been ignored, or old ones used instead.

So but typing “sudo apt-get install carla simulator” i get the error:

E: Unable to locate package carla-simulator

So i tried the Option B: Package Installation. I went to the repository on GitHub and dowloaded the version 0.9.8 ( I read that sice version 0.9.9 i could have problems with my Linux version). After that i unziped the package. But by trying to run CARLA on my terminal i get the now the following error:

“Cannot find a compatible Vulkan driver (ICD)”

Can anyone help me?

Thanks,

Lucas

The problem is that you need to install a driver for Vulkan.
Try with NVidia driver 4.10 or similar.
Also, if you are going to use the package without compiling, you can use any package version like 0.9.11, but we recommend Ubuntu 18 or 20 for that.
Regards

1 Like