Importing a Map with RoadRunner - Problem

Hi everyone,
I am using Ubuntu Melodic 18.04 and carla 0.9.10. I am trying to import a map into carla using RoadRunner.
I am following the tutorials provided here: map_tutorial_carla and this youtube video ( 15 minute ) : Data Ingestion Carla.

I have created a map in RoadRunner and exported the .fbx and the .xodr with all the .png textures. Following the tutorial I have copied the 2 files *.xodr and .fbx into the Import folder under carla/Import and I run: make import ARGS="--package package_name --no-carla-materials"

The first time the import process was perfect and I was able to visualize all the textures, props, assets in carla.

Then I have decided to make some changes to the map in RoadRunner, I have exported the new .xodr and .fbx file and copied them into the carla/Import folder and deleted the previously created “map_package” with sudo rm -r path/to/folder...

I have then launched make import (without ARGS) and everything run smoothly and the map is imported in Unreal, but this is the result:

Since the textures and materials are not shown, I have tried to launch make import ARGS="--package package_name --no-carla-materials"
but this time it’s not working and I receive this error:
make import ARGS="--package package_name --no-carla-material"*
parse-options: unrecognised option '--no-carla-material'
Usage: /home/username/carla/Util/BuildTools/Setup.sh [--python-version=VERSION]
Util/BuildTools/Linux.mk:143: recipe for target 'setup' failed
make: *** [setup] Error 2

If I try to run only make import ARGS="--package map_package" (or eventually make import ARGS="--package new_map_package" I get:
Creating makefile for map_package (no existing makefile)
ERROR: Couldn't find target rules file for target 'map_package' in rules assembly 'UE4Rules,Version=0.0.0.0, Culture=neutral, PublicKeyToken=null’.
Location: /home/username/UnrealEngine_4.24/Engine/Intermediate/Build/BuildRules/UE4Rules.dll
Target rules found:Makefile:290: recipe for target ‘CarlaUE4Editor’ failedmake[1]: *** [CarlaUE4Editor] Error 5make[1]: Leaving directory '/home/username/carla/Unreal/CarlaUE4
Util/BuildTools/Linux.mk:83: recipe for target ‘CarlaUE4Editor’ failed
make: *** [CarlaUE4Editor] Error 2

Any suggestions on how to import the textures in the map created or how to fix the make import with ARGS?
Thanks

Hi,

As for the second time you try to import the map with the same name, in our documentation, It talks about that it can lead to problems.

https://carla.readthedocs.io/en/latest/tuto_A_add_map/#add-a-new-map

My suggestion is to delete all in the folder of Import and put it again. And create a package with a different name.

Hi @Xavi, thanks for your reply! I did as you suggested:

  1. removed all files from the Import folder
  2. put again all the files in the Import folder
  3. run make import ARGS="--package Package01 --no-carla-materials", however I get the same error as previous:
    parse-options: unrecognised option '--no-carla-material'
    Usage: /home/username/carla/Util/BuildTools/Setup.sh [--python-version=VERSION]
    Util/BuildTools/Linux.mk:143: recipe for target 'setup' failed
    make: *** [setup] Error 2

Eventually I tried to launch only make import ARGS="--package Package01" but I get the following error again:

Creating makefile for Package01 (no existing makefile)
ERROR: Couldn't find target rules file for target 'Package01' in rules assembly 'UE4Rules,Version=0.0.0.0, Culture=neutral, PublicKeyToken=null’.
Location: /home/username/UnrealEngine_4.24/Engine/Intermediate/Build/BuildRules/UE4Rules.dll
Target rules found:Makefile:290: recipe for target ‘CarlaUE4Editor’ failedmake[1]: *** [CarlaUE4Editor]Error 5make[1]: Leaving directory '/home/username/carla/Unreal/CarlaUE4
Util/BuildTools/Linux.mk:83: recipe for target ‘CarlaUE4Editor’ failed
`make: *** [CarlaUE4Editor] Error 2``

It seems to me that I am unable to correctly create the package and launch make import with ARGS. Could this depend on the version of python I use to launch make import (at the moment I launch with python --version = 2.7.17)? or do you have any more suggestions?