Error while installing dependencies

When I run the following command :

sudo apt-get install build-essential clang-8 lld-8 g+±7 cmake ninja-build libvulkan1 python python-pip python-dev python3-dev python3-pip libpng-dev libtiff5-dev libjpeg-dev tzdata sed curl unzip autoconf libtool rsync libxml2-dev libxerces-c-dev &&

pip2 install --user setuptools &&
pip3 install --user -Iv setuptools==47.3.1 &&
pip2 install --user distro &&
pip3 install --user distro

I get the following error :

Reading package lists… Done
Building dependency tree
Reading state information… Done
autoconf is already the newest version (2.69-11).
build-essential is already the newest version (12.4ubuntu1).
libjpeg-dev is already the newest version (8c-2ubuntu8).
libtool is already the newest version (2.4.6-2).
python is already the newest version (2.7.15~rc1-1).
python-dev is already the newest version (2.7.15~rc1-1).
sed is already the newest version (4.4-2).
unzip is already the newest version (6.0-21ubuntu1).
libxerces-c-dev is already the newest version (3.2.0+debian-2).
ninja-build is already the newest version (1.8.2-1).
cmake is already the newest version (3.10.2-1ubuntu2.18.04.1).
curl is already the newest version (7.58.0-2ubuntu3.9).
g+±7 is already the newest version (7.5.0-3ubuntu1~18.04).
libpng-dev is already the newest version (1.6.34-1ubuntu0.18.04.2).
libtiff5-dev is already the newest version (4.0.9-5ubuntu0.3).
libxml2-dev is already the newest version (2.9.4+dfsg1-6.1ubuntu1.3).
python3-dev is already the newest version (3.6.7-1~18.04).
rsync is already the newest version (3.1.2-2.1ubuntu1.1).
tzdata is already the newest version (2020a-0ubuntu0.18.04).
libvulkan1 is already the newest version (1.1.70+dfsg1-1ubuntu0.18.04.1).
python-pip is already the newest version (9.0.1-2.3~ubuntu1.18.04.1).
python3-pip is already the newest version (9.0.1-2.3~ubuntu1.18.04.1).
clang-8 is already the newest version (1:8.0.1+svn369350-1~exp1~20200114191400.80).
lld-8 is already the newest version (1:8.0.1+svn369350-1~exp1~20200114191400.80).
The following packages were automatically installed and are no longer required:
libfwup1 libllvm9 libobjc-5-dev
Use ‘sudo apt autoremove’ to remove them.
0 upgraded, 0 newly installed, 0 to remove and 7 not upgraded.
Collecting setuptools
Using cached https://files.pythonhosted.org/packages/e1/b7/182161210a13158cd3ccc41ee19aadef54496b74f2817cc147006ec932b4/setuptools-44.1.1-py2.py3-none-any.whl
Installing collected packages: setuptools
Exception:
Traceback (most recent call last):
File “/usr/lib/python2.7/dist-packages/pip/basecommand.py”, line 215, in main
status = self.run(options, args)
File “/usr/lib/python2.7/dist-packages/pip/commands/install.py”, line 360, in run
prefix=options.prefix_path,
File “/usr/lib/python2.7/dist-packages/pip/req/req_set.py”, line 784, in install
**kwargs
File “/usr/lib/python2.7/dist-packages/pip/req/req_install.py”, line 851, in install
self.move_wheel_files(self.source_dir, root=root, prefix=prefix)
File “/usr/lib/python2.7/dist-packages/pip/req/req_install.py”, line 1064, in move_wheel_files
isolated=self.isolated,
File “/usr/lib/python2.7/dist-packages/pip/wheel.py”, line 478, in move_wheel_files
generated.extend(maker.make(spec))
File “/usr/share/python-wheels/distlib-0.2.6-py2.py3-none-any.whl/distlib/scripts.py”, line 403, in make
self._make_script(entry, filenames, options=options)
File “/usr/share/python-wheels/distlib-0.2.6-py2.py3-none-any.whl/distlib/scripts.py”, line 307, in _make_script
self._write_script(scriptnames, shebang, script, filenames, ext)
File “/usr/share/python-wheels/distlib-0.2.6-py2.py3-none-any.whl/distlib/scripts.py”, line 281, in _write_script
self._fileop.write_binary_file(outname, script_bytes)
File “/usr/share/python-wheels/distlib-0.2.6-py2.py3-none-any.whl/distlib/util.py”, line 548, in write_binary_file
with open(path, ‘wb’) as f:
IOError: [Errno 20] Not a directory: ‘/home/jaskaran/.local/bin/easy_install’

Please help