Create semantic tags Does not work

Hallo everybody,

i followed the instructions on Create semantic tags to create my custom tags.

  1. I created two new folders, ChevronSign and YellowLine

  2. Then i added the tags to ObjectLabel.h in LibCarla/source/carla/rpc

  3. Then i edited Tagger.cpp in Unreal/CarlaUE4/Plugins/Carla/Source/Carla/Game

  4. And finally defined a color code in CityScapesPalette.h in LibCarla/source/carla/image.

I moved the assets in the according directory, and they appear black, so no label. Moving the assets in one of the default folders works just fine, the semantic tag gets displayed correct.

What i tried:

  1. I changed the color of a default label and checked if the color would change. It did not.
  2. I tried to rebuild carla with make CarlaUE4Editor, and an error because of the new tags:
/carla/Unreal/CarlaUE4/Plugins/Carla/Source/Carla/Game/Tagger.cpp:48:67: error: no member named 'ChevronSign' in 'carla::rpc::CityObjectLabel'
  else if (String == "ChevronSign")  return crp::CityObjectLabel::ChevronSign;

/carla/Unreal/CarlaUE4/Plugins/Carla/Source/Carla/Game/Tagger.cpp:49:67: error: no member named 'YellowLine' in 'carla::rpc::CityObjectLabel'
  else if (String == "YellowLine")   return crp::CityObjectLabel::YellowLine;
  1. So i checked if there are other ObjectLabel.h files in my system and customized all of them as the first one. I found 3 of them.
    Screenshot%20from%202021-01-09%2021-02-55

Then the i ran make CarlaUE4Editor sucessfully. But the Semantic Tags still don’t work.

Does anyone know which mistake i made? Is there a mistake in the documentation?

Thanks in advance!

I found the mistake. I just had to upgrade from carla 0.9.9 to 0.9.10.